A downloadable mod

Compatible with patch 1.83 / Carnaval Streetwear

This script enables modders to add new trait inheritance rules to the TRAIT_INHERITANCE data structure contained within trait_tracker.py and thus eliminates any override conflicts.

Using this mod is very simple as it uses the exact same structure for trait inheritance as the game's trait_tracker XML tuning. For ease of use, I have included an optional file which contains an example of a functional trait inheritance mod.

It is important to note that this is meant to be used with non-personality traits (Traits that you cannot select in CAS). Why? No idea, ask EA about it.

It is also important to note that, in these tests, parent A and B are interchangeable as the game tests both combinations.

StatusReleased
CategoryGame mod
Rating
Rated 5.0 out of 5 stars
(6 total ratings)
AuthorMAL22
Tagssims, tool

Install instructions

Copy MAL22_TraitTrackerInjector.ts4script to your Mods folder. Note that this script will not do anything without installing mods that make use of it.

Download

Download
MAL22_TraitTrackerInjector.ts4script 9 kB
Download
MAL22_TraitTrackerInjector_test.package 415 bytes

Development log

Comments

Log in with itch.io to leave a comment.

If I may ask,  if it is possible, do you think that you could make it so that Ghosts can FINALLY pass Traits to their offspring? I mean, that is assuming you have a Mod that allows Ghost Pregnancy. That would be really appreciated, because I am quite tired of having to look up cheat codes every time to make a ghost's child into a Ghost Child.

(+10)

Hello :) When will be update the injector mod for newest patch?

(+1)

I really want to thank you for this injector. I have already created four genetic mods using this. This is amazing!

Hello, Can I install these two files or just the one with the script?

(+1)

You only need the .ts4script file. The package is for modders or to test that the mod works.

Thank You very much for info

The update has been released and should fix the last exceptions that users have been getting.

I'm looking into the errors that occur and will release an update in the next few days.

This mod is great, but I think it needs to be updated to the new patch. Can't wait til it happens.

how do i save the file to keep it from leaving my mods folder

I think it needs to be updated, I appreciate the mod, but I'm getting errors everytime I open the games and I made sure to disable all other mods.

The listed script mod failed to load and should be removed or updated. Here's the error report:

The listed script mod failed to load and should be removed or updated. Failure: 'm22_trait_tracker_injector' (m22_trait_tracker_injector) No module named 'M22.files.error_utils' (ModuleNotFoundError: No module named 'M22.files.error_utils')

(+2)

I am using the latest version, and have been having issues for some time, this is the error I am receiving:

(formatted)

Failure: 'm22_trait_tracker_injector' (m22_trait_tracker_injector)       No module named 'M22.files.error_utils' (ModuleNotFoundError: No module named 'M22.files.error_utils') Traceback (most recent call last):    File "T:\InGame\Gameplay\Scripts\Core\sims4\importer\utils.py", line 120, in import_modules_by_path   File "<frozen importlib._bootstrap="">", line 983, in _find_and_load   File "<frozen importlib._bootstrap="">", line 967, in _find_and_load_unlocked   File "<frozen importlib._bootstrap="">", line 668, in _load_unlocked   File "<frozen importlib._bootstrap="">", line 638, in _load_backward_compatible   File "T:\InGame\Gameplay\Scripts\Core\sims4\importer\custom_import.py", line 196, in load_module   File "D:\mimil\Bureau\Sims 4 Python Script Workspace\My Script Mods\TraitTrackerInjector\temp\m22_trait_tracker_injector.py", line 6, in <module> ModuleNotFoundError: No module named 'M22.files.error_utils'rtim=0 ClientInfo isn't here</module></frozen></frozen></frozen></frozen>

Further info should you need it: 

(+1)

Having the same problem here

for some reason when I download the mod and it doesn't appear in my files and when I click show in folder is says removed... I've seen this comment a lot but I'm not sure if it's actually fixed.

I can't do anything about a file being removed or deleted from your computer's filesystem. Save the file as opposed to opening it and it should stick around. It's a ts4script file so it doesn't need to be opened.

every time I try to open the trait tracker injector when I download  the file it  gets removed or it says  I need permission please help! I really want to add the Royal mod to my sims 4 game. Thanks  in advance :)

What do you mean by "open"? This is a .ts4script file, you don't open it. You simply download the file and drop it in the mods folder.

I accidentally opened it with notepad on my windows 10 and now it won’t work 

Download it again. 🤷‍♀️ Keep in mind that this is a modders resource and it won't do anything on its own.

When will be update to newest patch 1.77?

I haven't received any messages from modders who rely on it for their own mods so it's safe to assume that it still works for 1.77 and requires no update.

Okay, thanks for info.

I am having trouble downloading. Is there another way I can download this file I need it for the royalty mod by llazyneiph

What sort of trouble are you having? If the file is being downloaded with a different extension you can simply change it back to what it should be. If that doesn't cut it you can join the r/thesims Discord server via Reddit. That's where I'm hanging out most of the time.

I used a different browser and that worked. Thank you!